Flynumber-->Voipstunt-->PBX-->Acrobits softphone


Who can help me out? I tried configuring the PBX but I don’t have a clue, also because I cannot fill in some fields. Maybe Flash does not work well in Safari/Firefox on Mac OS X 10.9?

I have two accounts one with Voipstunt and one with SMSdiscount including a DID number, but that number shows no CallerID when placing an outgoing call. So from what I understood, Flynumber could help me out by providing a number that shows CallerID.
I want to create the following setup:

When people dial my Flynumber, I want it forwarded to my Voipstunt account and/or my SMSdiscount account and have my Acrobits softphone ringing. If possible, when I don’t answer the phone in 30 seconds, i would like the call to be forwarded to voicemail.

Thanks in advance for your help.

Kind regards,


Hi Casper

As long as flash is up to date it should work fine, we seem to have the best results with Chrome

To dial out with your Flynumber you would be using our SIP accounts and it would eliminate voipstunt or SMSdiscount

You can contact them to see if they can have your Flynumber show up as the caller ID when making an outgoing call but thats not in our hands as you’re using their infrastructure to make the call

You can receive calls on your Acrobits from the FlyNumber for free, outgoing calls have a per min rate

No matter what config is setup in the PBX you can add a voicemail module and have the call go to voicemail

If you need help setting up the SIP don’t hesitate to send us a PM and we can do it on our side

Hello staff member,

I managed to set up CallerID with Voipstunt. Now…I want to forward Flynumber to Voipstunt, if not answered in 30 sec. forward to voicemail. I will not use Flynumber for dialing out. Is this setup possible?

When trying to setup the modules in Flynumber’s PBX Panel (in Chrome, like you recommended) , I dragged the “Phone Number” module on the grid and clicked the settings icon. I get the following message “You have no available numbers. Please order more numbers to continue”.

I believe the modules must be configured like this:
Phone number–>Person–>Voicemail

When selecting the “Person” module and then settings–>Enter Name–>Voip–>ITSP SIP Forward. The “Username” and “Choose ITSP” fields can’t be edited.

Absolutely, You can do this directly from the My Account > My FlyNumbers page or use the PBX[quote=“cvt, post:3, topic:148”]
When trying to setup the modules in Flynumber’s PBX Panel (in Chrome, like you recommended) , I dragged the “Phone Number” module on the grid and clicked the settings icon. I get the following message “You have no available numbers. Please order more numbers to continue”.

You will first need to change the forwarding of the number to PBX/ Virtual Phone System , I went into your account and did this for you - it now shows up OK

Yes you are correct, I’ve gone ahead and set this up for you on your PBX gird, we uploaded a generic voice-mail message so I’m not sure if you’ll want to change that

Although there is no blinking cursor in some cases you can still type, you can also select custom and enter your SIP uri - we already entered your SMSdiscount info into the person module

Open up your PBX and you can see the changes

Please let us know if we can be of further assistance

Thank you very much. Unfortunately, I need some more assistance.

I have uploaded a new playlist but when it’s assigned to the block the caller only hears a loud hiss. I have recorded a custom voicemail message as well, a pop-up then comes up asking access to your microphone, allowed it, recorded the message and when it finished uploading i replayed there was no sound. The caller does not hear the message played, only the beep.


Seems to be an issue locally, could be your microphone or a security setting to allow the microphone to pick up sound in the browser

You can also upload your own file ( mp3 too), I just setup a generic voicemail for you. If you click the play button you can hear the message

When I click the play button for the voicemail greeting you uploaded its just silence, this would lead me to believe its a config issue on your side as the sound never reached our servers

Let us know if we can be of further assistance

What about the playlist? When the account it was set up by support initially, the caller could here a song first before being forwarded to voicemail. I thought that was a really nice feature. Now the caller just gets forwarded to voicemail only.

This is because there is something wrong on your side with the forwarding destination and its going directly into the FlyNumber voicemail

You’re sending the calls to your SMSdiscount account and we’re getting a “Busy Here” response when sending the calls there. You can see this in your call history as well.

Let us know if you run into any other issues

This was said by a staff member 4 days ago at the moment of writing. I did not change the setup. The only things that changed are the upload and deletion of files.

I have uploaded my own file and it works, thanks

When I click play in my playlist,I hear sound and it’s assigned to the block.

Please help. It was working before.

I understand, the issue though is we are sending the calls to your destination and its up to your device/software or provider to render the calls, your FlyNumber is one of the most reliable we have- I also went into your PBX , changed the forwarding to my 3rd party SIP account and the calls came in OK

I see there are some recent OK calls so hopefully this OK now

I also tested this and was able to hear the classical music but changed the song, it could be the song was a bad apple

You can upload your own MP3 as well, if you remove the playlist it will just ring normally

Let us know if you run into anything else

It’s the previous playlists that I uploaded that are interfering with the current playlist (test2, with the classical song). I have deleted all previous playlists, including the first one playlist i made (test, with song from Amy Winehouse)
I assigned the classical song to the block and i heard Amy Winehouse when i called my own number.

Please delete all playlists from your system (not in the PBX because even if deleted, the song is still there, then i will set up a new playlist in the PBX then it must work like it did before. Thanks

Also please have a look at the call log starting time 19:54:08, i request a verification call back from SMSdiscount’s voice system. When I answer the call, i hear a few beeps and the line is disconnected. This was three times in a row. When the call was disconnected, the voice system was forwarded to voicemail where it left a verification code.
So the Flynumber got verified, but it is NOT normal that the call gets disconnected. I know because i had other numbers verified through SMSdiscount as well.

And…I tried to update my Timezone in Account Details. It shows that the new entry is saved, then when the page is refreshed, it shows New York again.

Please trash your modules and create new ones, seems a conflict was created , we tested from your account and it works OK from our side

Is there a log from them, once we send the call we can’t control what SMSdiscount does with it

This is just for basic account settings, not for call history- for now it shows call history in GMT only. We hope to give the users the ability to change this in the future